use strict;
my $str = 'abdcdd fijfokkkmAS/+=
assdoifjfjidodijfjjjDDD';
my $regex = qr/(((\r?\n|\s)*[A-Za-z0-9+\/]){4})*(((\r?\n|\s)*[A-Za-z0-9+\/]){2}((\r?\n|\s)*=){2}|((\r?\n|\s)*[A-Za-z0-9+\/]){3}((\r?\n|\s)*=){1})?/mp;
my $subst = '<<<$0>>>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";