re = /(((\r?\n|\s)*[A-Za-z0-9+\/]){4})*(((\r?\n|\s)*[A-Za-z0-9+\/]){2}((\r?\n|\s)*=){2}|((\r?\n|\s)*[A-Za-z0-9+\/]){3}((\r?\n|\s)*=){1})?/m
str = 'abdcdd fijfokkkmAS/+=
assdoifjfjidodijfjjjDDD'
subst = '<<<$0>>>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result