// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(((\r?\n|\s)*[A-Za-z0-9+\/]){4})*(((\r?\n|\s)*[A-Za-z0-9+\/]){2}((\r?\n|\s)*=){2}|((\r?\n|\s)*[A-Za-z0-9+\/]){3}((\r?\n|\s)*=){1})?").unwrap();
let string = "abdcdd fijfokkkmAS/+=
assdoifjfjidodijfjjjDDD";
let substitution = "<<<$0>>>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}