$re = '/(((\r?\n|\s)*[A-Za-z0-9+\/]){4})*(((\r?\n|\s)*[A-Za-z0-9+\/]){2}((\r?\n|\s)*=){2}|((\r?\n|\s)*[A-Za-z0-9+\/]){3}((\r?\n|\s)*=){1})?/m';
$str = 'abdcdd fijfokkkmAS/+=
assdoifjfjidodijfjjjDDD';
$subst = "<<<$0>>>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;