import re
regex = re.compile(r"(((\r?\n|\s)*[A-Za-z0-9+\/]){4})*(((\r?\n|\s)*[A-Za-z0-9+\/]){2}((\r?\n|\s)*=){2}|((\r?\n|\s)*[A-Za-z0-9+\/]){3}((\r?\n|\s)*=){1})?", flags=re.MULTILINE)
test_str = ("abdcdd fijfokkkmAS/+=\n\n"
"assdoifjfjidodijfjjjDDD")
subst = "<<<$0>>>"
result = regex.sub(subst, test_str)
if result:
print(result)