# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm//gm;t' <<< "pkg-name.0.15.0-6.x86_64.rpm"