package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm`)
var str = `pkg-name.0.15.0-6.x86_64.rpm`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}