re = /((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm/m
str = 'pkg-name.0.15.0-6.x86_64.rpm'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result