use strict;
my $str = 'pkg-name.0.15.0-6.x86_64.rpm';
my $regex = qr/((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";