import Foundation
let pattern = #"((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"pkg-name.0.15.0-6.x86_64.rpm"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)