const regex = /((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((.*)\\.\\d+\\.\\d+\\.\\d+-\\d+)\\.x86_64\\.rpm', 'gm')
const str = `pkg-name.0.15.0-6.x86_64.rpm`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);