using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm";
string substitution = @"";
string input = @"pkg-name.0.15.0-6.x86_64.rpm";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}