// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm").unwrap();
let string = "pkg-name.0.15.0-6.x86_64.rpm";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}