$re = '/((.*)\.\d+\.\d+\.\d+-\d+)\.x86_64\.rpm/m';
$str = 'pkg-name.0.15.0-6.x86_64.rpm';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;