# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(here\b.*?)\bstring\b/$1anotherString/m;t' <<< "this is a string test with a lot of string words here another string string there string here string."