re = /\b(here\b.*?)\bstring\b/m
str = 'this is a string test with a lot of string words here another string string there string here string.'
subst = '$1anotherString'
result = str.sub(re, subst)
# Print the result of the substitution
puts result