use strict;
my $str = 'this is a string test with a lot of string words here another string string there string here string.';
my $regex = qr/\b(here\b.*?)\bstring\b/mp;
my $subst = '$1anotherString';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";