$re = '/\b(here\b.*?)\bstring\b/m';
$str = 'this is a string test with a lot of string words here another string string there string here string.';
$subst = "$1anotherString";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;