using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(here\b.*?)\bstring\b";
string substitution = @"$1anotherString";
string input = @"this is a string test with a lot of string words here another string string there string here string.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}