const regex = /\b(here\b.*?)\bstring\b/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(here\\b.*?)\\bstring\\b', 'm')
const str = `this is a string test with a lot of string words here another string string there string here string.`;
const subst = `$1anotherString`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);