import re
regex = re.compile(r"\b(here\b.*?)\bstring\b", flags=re.MULTILINE)
test_str = "this is a string test with a lot of string words here another string string there string here string."
subst = "$1anotherString"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)