#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(here\b.*?)\bstring\b"
Local $sString = "this is a string test with a lot of string words here another string string there string here string."
Local $sSubst = "$1anotherString"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)