import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/[a-zA-Z0-9]{5}\\/((images|scripts|styles).*|(filemanager|index|500|400)\\.php|manifest\\.appcache|favicon\\.ico)";
final String string = "/md089/scripts/load.js\n"
+ "/md089/index.php\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}