use strict;
my $str = '/md089/scripts/load.js
/md089/index.php
';
my $regex = qr/\/[a-zA-Z0-9]{5}\/((images|scripts|styles).*|(filemanager|index|500|400)\.php|manifest\.appcache|favicon\.ico)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";