re = /\/[a-zA-Z0-9]{5}\/((images|scripts|styles).*|(filemanager|index|500|400)\.php|manifest\.appcache|favicon\.ico)/
str = '/md089/scripts/load.js
/md089/index.php
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result