$re = '/\/[a-zA-Z0-9]{5}\/((images|scripts|styles).*|(filemanager|index|500|400)\.php|manifest\.appcache|favicon\.ico)/';
$str = '/md089/scripts/load.js
/md089/index.php
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;