# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(.*?)"[\t\r ]+"(.*?)"(?=[ ]*$)/$1 $2/gm;t' <<< "\"a\" \"va\"
\"b\" \"vb\"
\"c\" \"vc\"
\"d\" \"vd\"
\"e\" \"ve\"
\"f\" \"vf\"
\"g\" \"vg\"
\"h\" \"vh\""