re = /"(.*?)"[\t\r ]+"(.*?)"(?=[ ]*$)/m
str = '"a" "va"
"b" "vb"
"c" "vc"
"d" "vd"
"e" "ve"
"f" "vf"
"g" "vg"
"h" "vh"'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result