import re
regex = re.compile(r"\"(.*?)\"[\t\r ]+\"(.*?)\"(?=[ ]*$)", flags=re.MULTILINE)
test_str = ("\"a\" \"va\"\n"
"\"b\" \"vb\"\n"
"\"c\" \"vc\"\n"
"\"d\" \"vd\" \n"
"\"e\" \"ve\"\n"
"\"f\" \"vf\" \n"
"\"g\" \"vg\"\n"
"\"h\" \"vh\"")
subst = "$1 $2"
result = regex.sub(subst, test_str)
if result:
print(result)