import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(.*?)\"[\\t\\r ]+\"(.*?)\"(?=[ ]*$)";
final String string = "\"a\" \"va\"\n"
+ "\"b\" \"vb\"\n"
+ "\"c\" \"vc\"\n"
+ "\"d\" \"vd\" \n"
+ "\"e\" \"ve\"\n"
+ "\"f\" \"vf\" \n"
+ "\"g\" \"vg\"\n"
+ "\"h\" \"vh\"";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}