use strict;
my $str = '"a" "va"
"b" "vb"
"c" "vc"
"d" "vd"
"e" "ve"
"f" "vf"
"g" "vg"
"h" "vh"';
my $regex = qr/"(.*?)"[\t\r ]+"(.*?)"(?=[ ]*$)/mp;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";