const regex = /"(.*?)"[\t\r ]+"(.*?)"(?=[ ]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(.*?)"[\\t\\r ]+"(.*?)"(?=[ ]*$)', 'gm')
const str = `"a" "va"
"b" "vb"
"c" "vc"
"d" "vd"
"e" "ve"
"f" "vf"
"g" "vg"
"h" "vh"`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);