# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg/$1Renamed.jpg/g;t' <<< "Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg"