using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg";
string substitution = @"$1Renamed.jpg";
string input = @"Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}