const regex = /([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\n=\\|\\^]|([^a-z]:|[^:])\\b[^:]+:)Example\\.jpg', 'g')
const str = `Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg`;
const subst = `$1Renamed.jpg`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);