$re = '/([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg/';
$str = 'Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg';
$subst = "$1Renamed.jpg";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;