import Foundation
let pattern = #"([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1Renamed.jpg"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)