import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\n=\\|\\^]|([^a-z]:|[^:])\\b[^:]+:)Example\\.jpg";
final String string = "Rename:\n"
+ "[[:File:Example.jpg]]\n"
+ "Example.jpg\n"
+ "File:Example.jpg\n"
+ "[[File:Example.jpg|thumb]]\n"
+ "logo=Example.jpg\n"
+ "Do not rename:\n"
+ "Example filename is Example.jpg\n"
+ "[[:ru:Файл:Example.jpg]]\n"
+ "[[b:en:File:Example.jpg]]\n"
+ "[[:c:File:Example.jpg]]\n"
+ "duplicate=c:File:Example.jpg";
final String subst = "$1Renamed.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}