// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg").unwrap();
let string = "Rename:
[[:File:Example.jpg]]
Example.jpg
File:Example.jpg
[[File:Example.jpg|thumb]]
logo=Example.jpg
Do not rename:
Example filename is Example.jpg
[[:ru:Файл:Example.jpg]]
[[b:en:File:Example.jpg]]
[[:c:File:Example.jpg]]
duplicate=c:File:Example.jpg";
let substitution = "$1Renamed.jpg";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}