#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([\n=\|\^]|([^a-z]:|[^:])\b[^:]+:)Example\.jpg"
Local $sString = "Rename:" & @CRLF & _
"[[:File:Example.jpg]]" & @CRLF & _
"Example.jpg" & @CRLF & _
"File:Example.jpg" & @CRLF & _
"[[File:Example.jpg|thumb]]" & @CRLF & _
"logo=Example.jpg" & @CRLF & _
"Do not rename:" & @CRLF & _
"Example filename is Example.jpg" & @CRLF & _
"[[:ru:Файл:Example.jpg]]" & @CRLF & _
"[[b:en:File:Example.jpg]]" & @CRLF & _
"[[:c:File:Example.jpg]]" & @CRLF & _
"duplicate=c:File:Example.jpg"
Local $sSubst = "$1Renamed.jpg"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)