# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/homo_seg-//gm;t' <<< "homo_seg-Val-abc-1-1
homo_seg-Beg-cdf-2-1
homo_seg-Try-gfh-3-2
homo_seg-Fuss-cdh-3-1"