# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"homo_seg-"
test_str = ("homo_seg-Val-abc-1-1\n"
"homo_seg-Beg-cdf-2-1\n"
"homo_seg-Try-gfh-3-2\n"
"homo_seg-Fuss-cdh-3-1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.