import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "homo_seg-";
final String string = "homo_seg-Val-abc-1-1\n"
+ "homo_seg-Beg-cdf-2-1\n"
+ "homo_seg-Try-gfh-3-2\n"
+ "homo_seg-Fuss-cdh-3-1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}