#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)homo_seg-"
Local $sString = "homo_seg-Val-abc-1-1" & @CRLF & _
"homo_seg-Beg-cdf-2-1" & @CRLF & _
"homo_seg-Try-gfh-3-2" & @CRLF & _
"homo_seg-Fuss-cdh-3-1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)