package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)homo_seg-`)
var str = `homo_seg-Val-abc-1-1
homo_seg-Beg-cdf-2-1
homo_seg-Try-gfh-3-2
homo_seg-Fuss-cdh-3-1`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}