// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)homo_seg-").unwrap();
let string = "homo_seg-Val-abc-1-1
homo_seg-Beg-cdf-2-1
homo_seg-Try-gfh-3-2
homo_seg-Fuss-cdh-3-1";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}