using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"homo_seg-";
string substitution = @"";
string input = @"homo_seg-Val-abc-1-1
homo_seg-Beg-cdf-2-1
homo_seg-Try-gfh-3-2
homo_seg-Fuss-cdh-3-1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}