# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\^\s*(\(.*.\)|\S+)/<sup>$1<\/sup>/g;t' <<< "x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5"