import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\^\\s*(\\(.*.\\)|\\S+)";
final String string = "x ^ 2 -> x²\n"
+ "x ^ (2 - 6)\n"
+ "x ^ (2 - [6 + {x + y }])\n"
+ "x ^ y\n"
+ "3x ^ 7y\n"
+ "z ^ y2\n"
+ "9 ^ √4\n"
+ "9 ^ 30\n"
+ "2^1000000\n"
+ "x ^ (2 - 1) + 3 - 5";
final String subst = "<sup>$1</sup>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}