package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\^\s*(\(.*.\)|\S+)`)
var str = `x ^ 2 -> x²
x ^ (2 - 6)
x ^ (2 - [6 + {x + y }])
x ^ y
3x ^ 7y
z ^ y2
9 ^ √4
9 ^ 30
2^1000000
x ^ (2 - 1) + 3 - 5`
var substitution = "<sup>$1</sup>"
fmt.Println(re.ReplaceAllString(str, substitution))
}